This error message is usually an indication that the VC++ runtime is missing on a system.

Downloading and installing the Microsoft VC++ runtime that matches the version you need will fix this problem.  To find the redistributable at microsoft.com, Google using this search string “visual c++ redistributable 2005”.  Substitute “2008”, “2002”, or “2003” for different versions…

For example, one recent Chilkat customer had this error message in Java:

java.lang.UnsatisfiedLinkError: C:\temp\new\chilkat.dll: This
application has failed to start because the application
configuration is incorrect. Reinstalling the application may fix this problem

The Chilkat modules/libs for Java, Perl, Python, and Ruby are compiled using Visual C++ 2005 (not SP1), so you would need the runtime for that version (i.e. VC++ 8.0).


This is the same error message in Czech:

Spustení této aplikace se nezdarilo, protoze konfigurace není správná. Tyto potíze lze pravdepodobne vyresit opakovanou instalací aplikace.