This just came to our attention. When sending email using Exchange Server, a Ms-Exch-SMTP-Submit Permissions problem seems like an incorrect login/password error. A sample of the Chilkat.MailMan’s LastErrorXml is shown below. To get more information, Google “Ms-Exch-SMTP-Submit permission”…

<ChilkatLog>
<SendEmail>
<DllDate>Mar  6 2009</DllDate>
<UnlockPrefix>anything for 30-day trial</UnlockPrefix>
<Username>***</Username>
<Component>Java</Component>
<Recipients>
<NumTo>1</NumTo>
<To>***</To>
<NumCC>0</NumCC>
<NumBCC>0</NumBCC>
</Recipients>
<info>Need new SMTP connection</info>
<SMTP_Connect>
<info>Connecting to SMTP server smtp.***.net:25</info>
<smtp_host>smtp.***.net</smtp_host>
<smtp_port>25</smtp_port>
<smtp_user>***</smtp_user>
<InitialResponse><![CDATA[220 smtp.***.net Microsoft ESMTP MAIL Service ready at Thu, 12 Mar 2009 10:33:32 -0700
]]></InitialResponse>
<info>Sending STARTTLS (1)...</info>
<info>Received 503 SMTP Status...</info>
<info>Resending STARTTLS...</info>
<info>SSL Server Certificate verified.</info>
<ConnectionInfo>
<protocol>TLS1</protocol>
<cipher>ARC4</cipher>
<cipherStrength>128</cipherStrength>
<hash>MD5</hash>
<hashStrength>128</hashStrength>
<keyExchange>RSA</keyExchange>
<keyExchangeStrength>1024</keyExchangeStrength>
</ConnectionInfo>
<info>Secure Channel Established.</info>
<info>TLS connection established.</info>
<sendingHello><![CDATA[EHLO ***
]]></sendingHello>
<helloResponse><![CDATA[250-smtp.***.net Hello [111.111.111.111]
250-SIZE 52428800
250-PIPELINING
250-ENHANCEDSTATUSCODES
250-AUTH LOGIN
250-8BITMIME
250-BINARYMIME
250 CHUNKING
]]></helloResponse>
<login_method>LOGIN</login_method>
<error>535 5.7.3 Authentication unsuccessful</error>
<error>Failed to get response to login password</error>
<info><![CDATA[220 smtp.***.net Microsoft ESMTP MAIL Service ready at Thu, 12 Mar 2009 10:33:32 -0700
503 5.5.2 Send hello first
250-smtp.***.net Hello [111.111.111.111]
250-SIZE 52428800
250-PIPELINING
250-ENHANCEDSTATUSCODES
250-STARTTLS
250-AUTH
250-8BITMIME
250-BINARYMIME
250 CHUNKING
220 2.0.0 SMTP server ready
250-smtp.***.net Hello [111.111.111.111]
250-SIZE 52428800
250-PIPELINING
250-ENHANCEDSTATUSCODES
250-AUTH LOGIN
250-8BITMIME
250-BINARYMIME
250 CHUNKING
AUTH LOGIN
334 AAAAAAAAAAAA
334 BBBBBBBBBBBB
535 5.7.3 Authentication unsuccessful
]]></info>
<info>Failed to login using LOGIN method</info>
</SMTP_Connect>
<error>Failed to connect to SMTP server.</error>
</SendEmail>
</ChilkatLog>