Chilkat v11.6.0 / v11.6.1 Release Notes
See Release Notes for Versions 11.6.0 and 11.6.1
See Release Notes for Versions 11.6.0 and 11.6.1
✨ New Features HttpCurl A new Chilkat class has been added: HttpCurl The Chilkat.HttpCurl class executes curl commands and can automatically resolve dependent values needed by a request. Variables such as {{access_token}}, {{site_id}}, or {{drive_id}} may appear in URLs, headers, query parameters, or request bodies. If a variable is not yet known, HttpCurl builds […]
✨ New Features Js A new Chilkat class has been added: Js is a minimal, standards-compliant JavaScript engine designed to embed JavaScript inside applications with very small footprint and fast startup. It executes JavaScript code inside an application without requiring a browser or large runtime. See About the Chilkat.Js JavaScript Engine Ai Provider — […]
Some good information from a Chilkat customer: It turns out the problem was that we were using a Visual Studio Web Site project type. Instead of this, we found that using a Visual Studio Web App project type works. A “site” runs in some whimpy web server on the developer machine that is only 32-bit, […]
Beginning with Chilkat v9.4.0, two new TCP socket performance properties, SoSndBuf and SoRcvBuf, will be added to each of the following Chilkat components/libs: FTP2, HTTP, SFTP, SSH, SshTunnel, IMAP, and MailMan (POP3/SMTP). These properties allow for the underlying socket’s send and receive buffer sizes to be set. These are socket options associated with the setsockopt […]
Twitter PIN-Based Autorization Examples are now available on http://www.example-code.com/
The OAuth functionality shown in this example is available in Chilkat v9.4.0 to be released in mid-December 2012. Pre-releases are available upon request by sending email to support@chilkatsoft.com. ASP: Twitter OAuth — Tweet to Your Own Account SQL Server: Twitter OAuth — Tweet to Your Own Account C#: Twitter OAuth — Tweet to Your Own […]
When programming in VB.NET or VB6, be careful that you are looking at the correct online examples. VB6 examples are located here. whereas VB.NET examples are located here. In VB6, it is the Chilkat ActiveX that is used, and return values (in general) are 1 for success and 0 for failure. However, in VB.NET, return […]
This is a good discussion about Understanding Remote SSH Shell Sessions.
Question: In the online reference documentation, it says that “bool UploadFileByName(string remoteFilePath, string localFilePath)” will return true if success or false for failure. My question is that how does your component know that the file had been transferred successfully? Does it get ACK from SFTP server or that only means that client had sent the […]
SSH RFC 4250 The Secure Shell (SSH) Protocol Assigned Numbers RFC 4251 The Secure Shell (SSH) Protocol Architecture RFC 4252 The Secure Shell (SSH) Authentication Protocol RFC 4253 The Secure Shell (SSH) Transport Layer Protocol RFC 4254 The Secure Shell (SSH) Connection Protocol RFC 4255 Using DNS to Securely Publish Secure Shell (SSH) Key Fingerprints […]
The Chilkat Objective-C / C++ libs are now available for iOS 6.0. This supports the iPhone5 w/ both armv7 and armv7s. See Chilkat iOS library downloads
After successfully sending cca 250 e-mails I have error: DECLARE @hr int DECLARE @sTmp0 nvarchar(4000) — The mailman object is used for sending and receiving email. DECLARE @mailman int EXEC @hr = sp_OACreate ‘Chilkat.MailMan2’, @mailman OUT select @hr — -2147024882 select @mailman — null The solution is to call sp_OADestroy when finished with each of […]